Increased Error Rate For Data Collection
Incident Report for Apteligent
Resolved
This incident has been resolved.
Posted 2 months ago. Apr 21, 2017 - 20:01 PDT
Investigating
We're investigating an issue with our data collection systems.
Posted 2 months ago. Apr 21, 2017 - 14:34 PDT